Bienvenidos

Todos estos pasos descriptos fueron probados en ambientes productivos

viernes, 5 de agosto de 2011

Problema instalando una zona

Instalando una zona desde cero , me encontre con este error y  la solucion es artesanal, aca dejo el paso a paso.
[coneja]# zonecfg -z zona1 -f /usr/scripts/creaZONA1.ksh
[coneja]# zoneadm list -cv
  ID NAME             STATUS     PATH                           BRAND    IP
   0 global           running    /                              native   shared
   - zona1            configured /export/zona1                  native   shared
[coneja]# chmod 700 /export/zona1
[coneja]# zoneadm -z zona1 install
Preparing to install zone .
Creating list of files to copy from the global zone.
Copying <139425> files to the zone.
Initializing zone product registry.
Determining zone package initialization order.
Preparing to initialize <1171> packages on the zone.
Initialized <1171> packages on zone.                                 [[2;5~
Zone is initialized.
Installation of <12> packages was skipped.
The file contains a log of the zone installation.
HASTA ACA VENIA TODO PERFECTO........
[coneja]# zoneadm -z zona1 ready
[coneja] # zoneadm list -cv
  ID NAME             STATUS     PATH                           BRAND    IP
   0 global           running    /                              native   shared
   1 zona1            ready      /export/zona1                  native   shared
[coneja] # zoneadm -z zona1 boot
[coneja]# zlogin zona1 ( Cuando Quiero loguearme a la zona, que instale recien, no levantaban servicios)
# svcs -xv
svc:/system/sysidtool:net (sysidtool)
 State: offline since Mon May 18 10:02:53 2009
Reason: Start method is running.
   See: http://sun.com/msg/SMF-8000-C4
   See: man -M /usr/man -s 1M sysidtool
   See: /var/svc/log/system-sysidtool:net.log
Impact: 28 dependent services are not running:
        svc:/network/rpc/bind:default
Recorté la salida de los logs del svcs -xv        
   See: /var/svc/log/application-print-ppd-cache-update:default.log
Impact: This service is not running.
#                                                        
LO UNICO LOCO QUE VEO ES en el /ETC
-rw-r--r--   1 root     other          0 May 18 09:44 .UNCONFIGURED
-rw-r--r--   1 root     other         40 May 18 09:51 .sysidconfig.apps
# more .sysidconfig.apps
/usr/sbin/sysidkbd
/lib/svc/method/sshd
LUEGO APLICO la SOLUCION  de la Ing SCIARRILLO
# rm .UNCONFIGURED
# rm .sysidconfig.apps
# reboot    ( reboot de la zona)
[Connection to zone 'zona1' pts/2 closed]
[coneja]# zoneadm list -cv
  ID NAME             STATUS     PATH                           BRAND    IP
   0 global           running    /                              native   shared
   2 zona1            running    /export/zona1                  native   shared
[coneja] /usr/scripts #                    
Ejecuto esto
    /usr/sbin/sysidnet
     /usr/sbin/sysidns
     /usr/sbin/sysidsys
     /usr/sbin/sysidroot
     /usr/sbin/sysidpm
     /usr/sbin/sysidnfs4
     /usr/sbin/sysidkbd

y Salio Andando 10 PuntoS

2 comentarios:

  1. Es común que pasara eso, después que la instala y booteas por primera ves tenes que entrar con zlogin -C y te va a pedir los datos de red, nombre, password.
    Después de la instalación queda configurada para correr lo mismo que después de un sys-unconfig.

    Saludos, Adrián.

    ResponderEliminar
  2. Si Adrian, me paso en el 2006 con los primeros releases de Solaris 10, me volvi loco.

    ResponderEliminar